WSVR0009E: Error occurred during startup Cannot get canonical host name for server

 [3/8/10 20:38:05:592 PST] 0000000a WsServerImpl  E   WSVR0009E: Error occurred during startup
META-INF/ws-server-components.xml
[3/8/10 20:38:05:602 PST] 0000000a WsServerImpl  E   WSVR0009E: Error occurred during startup
com.ibm.ws.exception.ConfigurationError: com.ibm.ws.exception.ConfigurationError: javax.naming.ConfigurationException: Cannot get canonical host name for server.
        at com.ibm.ws.runtime.WsServerImpl.bootServerContainer(WsServerImpl.java:184)
        at com.ibm.ws.runtime.WsServerImpl.start(WsServerImpl.java:139)


Caused by: javax.naming.ConfigurationException: Cannot get canonical host name for server.
        at com.ibm.ws.security.core.SecurityConfig.getHostName(SecurityConfig.java:2476)
        at com.ibm.ws.security.core.SecurityConfig.setValues(SecurityConfig.java:1041)
        at com.ibm.ws.security.core.distSecurityComponentImpl.initializeSecurityConfig(distSecurityComponentImpl.java:776)
        at com.ibm.ws.security.core.distSecurityComponentImpl.initialize(distSecurityComponentImpl.java:224)
        ... 27 more
Have you ever faced any such errors while starting the Websphere server ?

Resolving the problem
Ensure that the naming resolution works for the host name. In the example, the name lookup failed for host name.Run the following two commands and ensure that they return the correct information.

nslookup `hostname`
nslookup

If both are fine try to create entries in /etc/hosts file by resolving the IP of the host.
some thing like below
 #
# hosts         This file describes a number of hostname-to-address
#               mappings for the TCP/IP subsystem.  It is mostly
#               used at boot time, when no name servers are running.
#               On small systems, this file can be used instead of a
#               "named" name server.
# Syntax:
#
# IP-Address  Full-Qualified-Hostname  Short-Hostname
#
127.0.0.2       nc184120.tivlab.austin.ibm.com.tivlab.austin.ibm.com nc184120.tivlab.austin.ibm.com nc184120
9.48.184.120    nc184120 nc184120.tivlab.austin.ibm.com
Hope this will help solving ur problem


0 comments to "WSVR0009E: Error occurred during startup Cannot get canonical host name for server"

Post a Comment

Who ever writes Inappropriate/Vulgar comments to context, generally want to be anonymous …So I hope U r not the one like that?
For lazy logs u can at least use Name/URL option which don’t even require any sign-in, good thing is that it can accept your lovely nick name also and URL is not mandatory too.
Thanks for your patience
~Krishna(I love "Transparency")
వీలయితే నాల్గు పోస్టులు ...కుదురితే ఒక కామెంటూ ...

Translate

Enter your email address:

Buffs ...

Visitors


hits counter
View My StatsCheck Google Page Rank

Add to Google Reader or Homepage

Bookmark and Share

Tags


Powered by WidgetsForFree

Archives